BrainVISA's python crashes after last Ubuntu16 upgrade

Questions about BrainVisa usage and installation

Moderators: riviere, denghien

francois
Posts: 59
Joined: Tue Jul 25, 2017 9:37 am

BrainVISA's python crashes after last Ubuntu16 upgrade

Postby francois » Wed Feb 27, 2019 12:24 pm

Hello

After a recent upgrade of Ubuntu 16 packages, BrainVISA 4.6.1 and the most recent 4.6.1 stopped working.
It already happens on two of our computers: a native Ubuntu 16, and my Ubuntu 16 running on Windows 10/WSL.

After setting up the brainvisa python environment (source /path/bv4.6.2/bin/bv_env.sh /path/bv4.6.2), any call to python crashes.

Code: Select all

ftadel@DESKTOP-SQA66ET:~/IntrAnat$ python
Python 2.7.12 (default, Dec  4 2017, 14:50:18)
[GCC 5.4.0 20160609] on linux2
Type "help", "copyright", "credits" or "license" for more information.
Segmentation fault (core dumped)


On my laptop, the packages that were upgraded last are the following:

Code: Select all

  apparmor apt apt-transport-https apt-utils base-files bind9-host binutils ca-certificates cloud-init cloud-initramfs-copymods
  cloud-initramfs-dyn-netconf curl distro-info-data dnsutils dpkg dpkg-dev ffmpeg firefox friendly-recovery fsl-5.0-core gcc-6-base gcc-7-base
  gettext gettext-base gir1.2-packagekitglib-1.0 git git-man gitk gnome-keyring hwdata initramfs-tools initramfs-tools-bin
  initramfs-tools-core iproute2 kmod krb5-locales libapparmor-perl libapparmor1 libapt-inst2.0 libapt-pkg-dev libapt-pkg5.0 libarchive13
  libasprintf-dev libasprintf0v5 libav-tools libavahi-client3 libavahi-common-data libavahi-common3 libavahi-glib1 libavcodec-ffmpeg56
  libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2 libavutil-ffmpeg54 libbind9-140 libc-bin libc-dev-bin
  libc6 libc6-dev libcaca0 libcilkrts5 libcups2 libcurl3 libcurl3-gnutls libdns-export162 libdns162 libdpkg-perl libgd3 libgettextpo-dev
  libgettextpo0 libgfortran3 libglib2.0-0 libglib2.0-data libgssapi-krb5-2 libhdf5-10 libisc-export160 libisc160 libisccc140 libisccfg140
  libk5crypto3 libkmod2 libkrb5-3 libkrb5support0 liblcms2-2 libldap-2.4-2 libldb1 liblwres141 libmspack0 libmysqlclient20 libnss3
  libnss3-nssdb libopencv-core2.4v5 libopencv-imgproc2.4v5 libp11-kit-gnome-keyring libpackagekit-glib2-16 libpam-gnome-keyring libpam-systemd
  libpci3 libperl5.22 libpolkit-agent-1-0 libpolkit-backend-1-0 libpolkit-gobject-1-0 libpostproc-ffmpeg53 libpython2.7 libpython2.7-dev
  libpython2.7-minimal libpython2.7-stdlib libpython3.5 libpython3.5-minimal libpython3.5-stdlib libsasl2-2 libsasl2-modules
  libsasl2-modules-db libsmbclient libsqlite3-0 libssh-gcrypt-4 libssl1.0.0 libswresample-ffmpeg1 libswscale-ffmpeg3 libsystemd0 libtiff5
  libubsan0 libudev1 libwavpack1 libwbclient0 libx11-6 libx11-data libx11-dev libx11-doc libx11-xcb-dev libx11-xcb1 libxkbcommon0
  linux-libc-dev locales multiarch-support mysql-common neurodebian neurodebian-archive-keyring neurodebian-popularity-contest open-iscsi
  openjdk-8-jdk openjdk-8-jdk-headless openjdk-8-jre openjdk-8-jre-headless openssh-client openssh-server openssh-sftp-server openssl
  overlayroot pciutils perl perl-base perl-modules-5.22 policykit-1 python2.7 python2.7-dev python2.7-minimal python3-cryptography
  python3-distupgrade python3-requests python3-software-properties python3-update-manager python3-urllib3 python3.5 python3.5-minimal
  samba-libs snapd software-properties-common sosreport ssh systemd systemd-sysv tzdata ubuntu-core-launcher ubuntu-minimal
  ubuntu-release-upgrader-core ubuntu-standard udev unattended-upgrades update-manager-core update-notifier-common


We don't have any way to start BrainVISA anymore...
What should we do?

Thanks
François

francois
Posts: 59
Joined: Tue Jul 25, 2017 9:37 am

Re: BrainVISA's python crashes after last Ubuntu16 upgrade

Postby francois » Wed Feb 27, 2019 12:56 pm

Detail of the packages that were upgrade yesterday, causing BrainVISA to crash:

Code: Select all

2019-02-26 08:30:03 upgrade dkms:all 2.2.0.3-2ubuntu11.5 2.2.0.3-2ubuntu11.6
2019-02-26 08:30:04 upgrade shim-signed:amd64 1.33.1~16.04.3+15+1533136590.3beb971-0ubuntu1 1.33.1~16.04.4+15+1533136590.3beb971-0ubuntu1
2019-02-26 08:30:04 upgrade snapd:amd64 2.34.2 2.34.2ubuntu0.1
2019-02-26 08:30:51 upgrade base-files:amd64 9.4ubuntu4.7 9.4ubuntu4.8
2019-02-26 08:31:13 upgrade libc6-dbg:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:13 upgrade libc6-i386:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:14 upgrade libc6-dev:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:15 upgrade libc-dev-bin:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:15 upgrade libc6:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:17 upgrade locales:all 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:18 upgrade libc-bin:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:19 upgrade libsystemd0:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:20 upgrade libpam-systemd:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:20 upgrade systemd:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:24 upgrade udev:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:24 upgrade libudev1:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:26 upgrade kmod:amd64 22-1ubuntu5.1 22-1ubuntu5.2
2019-02-26 08:31:26 upgrade libkmod2:amd64 22-1ubuntu5.1 22-1ubuntu5.2
2019-02-26 08:31:28 upgrade systemd-sysv:amd64 229-4ubuntu21.15 229-4ubuntu21.16
2019-02-26 08:31:29 upgrade multiarch-support:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-26 08:31:29 upgrade libisc-export160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:30 upgrade libdns-export162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:30 upgrade bind9-host:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:30 upgrade dnsutils:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:30 upgrade libisc160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:31 upgrade libdns162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:31 upgrade libisccc140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:31 upgrade libisccfg140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:32 upgrade liblwres141:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:32 upgrade libbind9-140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.11 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-26 08:31:32 upgrade pciutils:amd64 1:3.3.1-1.1ubuntu1.2 1:3.3.1-1.1ubuntu1.3
2019-02-26 08:31:33 upgrade libpci3:amd64 1:3.3.1-1.1ubuntu1.2 1:3.3.1-1.1ubuntu1.3
2019-02-26 08:31:33 upgrade binutils:amd64 2.26.1-1ubuntu1~16.04.7 2.26.1-1ubuntu1~16.04.8
2019-02-26 08:31:33 upgrade ghostscript:amd64 9.26~dfsg+0-0ubuntu0.16.04.4 9.26~dfsg+0-0ubuntu0.16.04.6
2019-02-26 08:31:34 upgrade ghostscript-x:amd64 9.26~dfsg+0-0ubuntu0.16.04.4 9.26~dfsg+0-0ubuntu0.16.04.6
2019-02-26 08:31:34 upgrade libgs9:amd64 9.26~dfsg+0-0ubuntu0.16.04.4 9.26~dfsg+0-0ubuntu0.16.04.6
2019-02-26 08:31:34 upgrade libgs9-common:all 9.26~dfsg+0-0ubuntu0.16.04.4 9.26~dfsg+0-0ubuntu0.16.04.6
2019-02-26 08:31:35 upgrade module-init-tools:all 22-1ubuntu5.1 22-1ubuntu5.2



Detail of all the packages that were upgraded on my Win10 laptop:

Code: Select all

2019-02-27 11:51:23 upgrade base-files:amd64 9.4ubuntu4.7 9.4ubuntu4.8
2019-02-27 11:51:29 upgrade dpkg:amd64 1.18.4ubuntu1.4 1.18.4ubuntu1.5
2019-02-27 11:51:45 upgrade libperl5.22:amd64 5.22.1-9ubuntu0.5 5.22.1-9ubuntu0.6
2019-02-27 11:51:49 upgrade perl:amd64 5.22.1-9ubuntu0.5 5.22.1-9ubuntu0.6
2019-02-27 11:51:50 upgrade perl-base:amd64 5.22.1-9ubuntu0.5 5.22.1-9ubuntu0.6
2019-02-27 11:51:59 upgrade perl-modules-5.22:all 5.22.1-9ubuntu0.5 5.22.1-9ubuntu0.6
2019-02-27 11:52:11 upgrade libc6-dev:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:52:17 upgrade libc-dev-bin:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:52:17 upgrade linux-libc-dev:amd64 4.4.0-133.159 4.4.0-142.168
2019-02-27 11:52:27 upgrade libc6:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:52:36 upgrade locales:all 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:52:43 upgrade libc-bin:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:52:47 upgrade libapt-pkg-dev:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:52:48 upgrade libapt-inst2.0:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:52:49 upgrade libapt-pkg5.0:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:52:50 upgrade apt:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:52:56 upgrade apt-utils:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:52:57 upgrade libsystemd0:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:52:59 upgrade libpam-systemd:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:53:00 upgrade systemd:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:53:12 upgrade udev:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:53:14 upgrade kmod:amd64 22-1ubuntu5 22-1ubuntu5.2
2019-02-27 11:53:14 upgrade libkmod2:amd64 22-1ubuntu5 22-1ubuntu5.2
2019-02-27 11:53:17 upgrade libudev1:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:53:18 upgrade friendly-recovery:all 0.2.31ubuntu1 0.2.31ubuntu2
2019-02-27 11:53:19 upgrade initramfs-tools:all 0.122ubuntu8.11 0.122ubuntu8.14
2019-02-27 11:53:19 upgrade initramfs-tools-core:all 0.122ubuntu8.11 0.122ubuntu8.14
2019-02-27 11:53:20 upgrade initramfs-tools-bin:amd64 0.122ubuntu8.11 0.122ubuntu8.14
2019-02-27 11:53:20 upgrade systemd-sysv:amd64 229-4ubuntu21.4 229-4ubuntu21.16
2019-02-27 11:53:23 upgrade libapparmor1:amd64 2.10.95-0ubuntu2.9 2.10.95-0ubuntu2.10
2019-02-27 11:53:24 upgrade libpython3.5:amd64 3.5.2-2ubuntu0~16.04.4 3.5.2-2ubuntu0~16.04.5
2019-02-27 11:53:24 upgrade libssl1.0.0:amd64 1.0.2g-1ubuntu4.13 1.0.2g-1ubuntu4.14
2019-02-27 11:53:25 upgrade python3.5:amd64 3.5.2-2ubuntu0~16.04.4 3.5.2-2ubuntu0~16.04.5
2019-02-27 11:53:26 upgrade libpython3.5-stdlib:amd64 3.5.2-2ubuntu0~16.04.4 3.5.2-2ubuntu0~16.04.5
2019-02-27 11:53:33 upgrade python3.5-minimal:amd64 3.5.2-2ubuntu0~16.04.4 3.5.2-2ubuntu0~16.04.5
2019-02-27 11:53:34 upgrade libpython3.5-minimal:amd64 3.5.2-2ubuntu0~16.04.4 3.5.2-2ubuntu0~16.04.5
2019-02-27 11:53:37 upgrade libsqlite3-0:amd64 3.11.0-1ubuntu1 3.11.0-1ubuntu1.1
2019-02-27 11:53:37 upgrade libglib2.0-0:amd64 2.48.2-0ubuntu4 2.48.2-0ubuntu4.1
2019-02-27 11:53:38 upgrade libp11-kit-gnome-keyring:amd64 3.18.3-0ubuntu2 3.18.3-0ubuntu2.1
2019-02-27 11:53:38 upgrade gnome-keyring:amd64 3.18.3-0ubuntu2 3.18.3-0ubuntu2.1
2019-02-27 11:53:40 upgrade libpam-gnome-keyring:amd64 3.18.3-0ubuntu2 3.18.3-0ubuntu2.1
2019-02-27 11:53:40 upgrade libk5crypto3:amd64 1.13.2+dfsg-5ubuntu2 1.13.2+dfsg-5ubuntu2.1
2019-02-27 11:53:40 upgrade libgssapi-krb5-2:amd64 1.13.2+dfsg-5ubuntu2 1.13.2+dfsg-5ubuntu2.1
2019-02-27 11:53:41 upgrade libkrb5-3:amd64 1.13.2+dfsg-5ubuntu2 1.13.2+dfsg-5ubuntu2.1
2019-02-27 11:53:41 upgrade libkrb5support0:amd64 1.13.2+dfsg-5ubuntu2 1.13.2+dfsg-5ubuntu2.1
2019-02-27 11:53:41 upgrade samba-libs:amd64 2:4.3.11+dfsg-0ubuntu0.16.04.15 2:4.3.11+dfsg-0ubuntu0.16.04.18
2019-02-27 11:53:43 upgrade libwbclient0:amd64 2:4.3.11+dfsg-0ubuntu0.16.04.15 2:4.3.11+dfsg-0ubuntu0.16.04.18
2019-02-27 11:53:44 upgrade libsmbclient:amd64 2:4.3.11+dfsg-0ubuntu0.16.04.15 2:4.3.11+dfsg-0ubuntu0.16.04.18
2019-02-27 11:53:44 upgrade libsasl2-modules-db:amd64 2.1.26.dfsg1-14build1 2.1.26.dfsg1-14ubuntu0.1
2019-02-27 11:53:44 upgrade libsasl2-2:amd64 2.1.26.dfsg1-14build1 2.1.26.dfsg1-14ubuntu0.1
2019-02-27 11:53:45 upgrade libldap-2.4-2:amd64 2.4.42+dfsg-2ubuntu3.3 2.4.42+dfsg-2ubuntu3.4
2019-02-27 11:53:45 upgrade libldb1:amd64 2:1.1.24-1ubuntu3 2:1.1.24-1ubuntu3.1
2019-02-27 11:53:45 upgrade libavahi-common-data:amd64 0.6.32~rc+dfsg-1ubuntu2.2 0.6.32~rc+dfsg-1ubuntu2.3
2019-02-27 11:53:46 upgrade libavahi-common3:amd64 0.6.32~rc+dfsg-1ubuntu2.2 0.6.32~rc+dfsg-1ubuntu2.3
2019-02-27 11:53:46 upgrade libavahi-client3:amd64 0.6.32~rc+dfsg-1ubuntu2.2 0.6.32~rc+dfsg-1ubuntu2.3
2019-02-27 11:53:46 upgrade libcups2:amd64 2.1.3-4ubuntu0.5 2.1.3-4ubuntu0.7
2019-02-27 11:53:46 upgrade python2.7-dev:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:47 upgrade python2.7:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:47 upgrade libpython2.7-dev:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:50 upgrade libpython2.7:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:51 upgrade libpython2.7-stdlib:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:57 upgrade python2.7-minimal:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:53:58 upgrade libpython2.7-minimal:amd64 2.7.12-1ubuntu0~16.04.3 2.7.12-1ubuntu0~16.04.4
2019-02-27 11:54:01 upgrade open-iscsi:amd64 2.0.873+git0.3b4b4500-14ubuntu3.5 2.0.873+git0.3b4b4500-14ubuntu3.7
2019-02-27 11:54:02 upgrade openssh-sftp-server:amd64 1:7.2p2-4ubuntu2.4 1:7.2p2-4ubuntu2.7
2019-02-27 11:54:02 upgrade openssh-server:amd64 1:7.2p2-4ubuntu2.4 1:7.2p2-4ubuntu2.7
2019-02-27 11:54:03 upgrade openssh-client:amd64 1:7.2p2-4ubuntu2.4 1:7.2p2-4ubuntu2.7
2019-02-27 11:54:03 upgrade ssh:all 1:7.2p2-4ubuntu2.4 1:7.2p2-4ubuntu2.7
2019-02-27 11:54:04 upgrade libapparmor-perl:amd64 2.10.95-0ubuntu2.9 2.10.95-0ubuntu2.10
2019-02-27 11:54:04 upgrade apparmor:amd64 2.10.95-0ubuntu2.9 2.10.95-0ubuntu2.10
2019-02-27 11:54:05 upgrade openssl:amd64 1.0.2g-1ubuntu4.13 1.0.2g-1ubuntu4.14
2019-02-27 11:54:06 upgrade ca-certificates:all 20170717~16.04.1 20170717~16.04.2
2019-02-27 11:54:08 upgrade ubuntu-core-launcher:amd64 2.34.2 2.34.2ubuntu0.1
2019-02-27 11:54:09 upgrade snapd:amd64 2.34.2 2.34.2ubuntu0.1
2019-02-27 11:54:11 upgrade ubuntu-release-upgrader-core:all 1:16.04.25 1:16.04.26
2019-02-27 11:54:11 status half-configured ubuntu-release-upgrader-core:all 1:16.04.25
2019-02-27 11:54:11 status unpacked ubuntu-release-upgrader-core:all 1:16.04.25
2019-02-27 11:54:11 status half-installed ubuntu-release-upgrader-core:all 1:16.04.25
2019-02-27 11:54:11 status half-installed ubuntu-release-upgrader-core:all 1:16.04.25
2019-02-27 11:54:11 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:54:11 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:54:12 upgrade python3-distupgrade:all 1:16.04.25 1:16.04.26
2019-02-27 11:54:12 status half-configured python3-distupgrade:all 1:16.04.25
2019-02-27 11:54:12 status unpacked python3-distupgrade:all 1:16.04.25
2019-02-27 11:54:12 status half-installed python3-distupgrade:all 1:16.04.25
2019-02-27 11:54:13 status half-installed python3-distupgrade:all 1:16.04.25
2019-02-27 11:54:13 status unpacked python3-distupgrade:all 1:16.04.26
2019-02-27 11:54:13 status unpacked python3-distupgrade:all 1:16.04.26
2019-02-27 11:54:13 upgrade update-manager-core:all 1:16.04.13 1:16.04.15
2019-02-27 11:54:13 upgrade python3-update-manager:all 1:16.04.13 1:16.04.15
2019-02-27 11:54:14 upgrade update-notifier-common:all 3.168.9 3.168.10
2019-02-27 11:54:16 upgrade multiarch-support:amd64 2.23-0ubuntu10 2.23-0ubuntu11
2019-02-27 11:54:21 upgrade libgfortran3:amd64 6.4.0-17ubuntu1~16.04 6.5.0-2ubuntu1~16.04
2019-02-27 11:54:21 upgrade gcc-6-base:amd64 6.4.0-17ubuntu1~16.04 6.5.0-2ubuntu1~16.04
2019-02-27 11:54:22 upgrade libcilkrts5:amd64 7.3.0-21ubuntu1~16.04 7.4.0-1ubuntu1~16.04~ppa1
2019-02-27 11:54:22 upgrade libubsan0:amd64 7.3.0-21ubuntu1~16.04 7.4.0-1ubuntu1~16.04~ppa1
2019-02-27 11:54:22 upgrade gcc-7-base:amd64 7.3.0-21ubuntu1~16.04 7.4.0-1ubuntu1~16.04~ppa1
2019-02-27 11:54:22 upgrade tzdata:all 2017c-0ubuntu0.16.04 2018i-0ubuntu0.16.04
2019-02-27 11:54:39 upgrade distro-info-data:all 0.28ubuntu0.8 0.28ubuntu0.9
2019-02-27 11:54:40 upgrade iproute2:amd64 4.3.0-1ubuntu3.16.04.3 4.3.0-1ubuntu3.16.04.4
2019-02-27 11:54:41 upgrade libisc-export160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:41 upgrade libdns-export162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:42 upgrade ubuntu-minimal:amd64 1.361.1 1.361.2
2019-02-27 11:54:42 upgrade curl:amd64 7.47.0-1ubuntu2.8 7.47.0-1ubuntu2.12
2019-02-27 11:54:42 upgrade libcurl3-gnutls:amd64 7.47.0-1ubuntu2.8 7.47.0-1ubuntu2.12
2019-02-27 11:54:42 upgrade apt-transport-https:amd64 1.2.27 1.2.29ubuntu0.1
2019-02-27 11:54:43 upgrade bind9-host:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:43 upgrade dnsutils:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:43 upgrade libisc160:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:43 upgrade libdns162:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:44 upgrade libisccc140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:44 upgrade libisccfg140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:44 upgrade liblwres141:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:45 upgrade libbind9-140:amd64 1:9.10.3.dfsg.P4-8ubuntu1.10 1:9.10.3.dfsg.P4-8ubuntu1.12
2019-02-27 11:54:45 upgrade libasprintf-dev:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:54:45 upgrade libasprintf0v5:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:54:45 upgrade gettext-base:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:54:46 upgrade krb5-locales:all 1.13.2+dfsg-5ubuntu2 1.13.2+dfsg-5ubuntu2.1
2019-02-27 11:54:46 upgrade libglib2.0-data:all 2.48.2-0ubuntu4 2.48.2-0ubuntu4.1
2019-02-27 11:54:46 upgrade pciutils:amd64 1:3.3.1-1.1ubuntu1.2 1:3.3.1-1.1ubuntu1.3
2019-02-27 11:54:47 upgrade libpci3:amd64 1:3.3.1-1.1ubuntu1.2 1:3.3.1-1.1ubuntu1.3
2019-02-27 11:54:47 upgrade libpolkit-gobject-1-0:amd64 0.105-14.1ubuntu0.1 0.105-14.1ubuntu0.4
2019-02-27 11:54:47 upgrade libsasl2-modules:amd64 2.1.26.dfsg1-14build1 2.1.26.dfsg1-14ubuntu0.1
2019-02-27 11:54:47 upgrade libx11-data:all 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:54:50 upgrade libx11-doc:all 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:54:58 upgrade libx11-dev:amd64 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:54:59 upgrade libx11-6:amd64 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:54:59 upgrade ubuntu-standard:amd64 1.361.1 1.361.2
2019-02-27 11:54:59 upgrade binutils:amd64 2.26.1-1ubuntu1~16.04.6 2.26.1-1ubuntu1~16.04.8
2019-02-27 11:55:02 upgrade dpkg-dev:all 1.18.4ubuntu1.4 1.18.4ubuntu1.5
2019-02-27 11:55:04 upgrade libdpkg-perl:all 1.18.4ubuntu1.4 1.18.4ubuntu1.5
2019-02-27 11:55:06 upgrade libavresample-ffmpeg2:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:06 upgrade libswresample-ffmpeg1:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:07 upgrade libpostproc-ffmpeg53:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:07 upgrade libswscale-ffmpeg3:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:07 upgrade libssh-gcrypt-4:amd64 0.6.3-4.3 0.6.3-4.3ubuntu0.2
2019-02-27 11:55:07 upgrade libavformat-ffmpeg56:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:08 upgrade libopencv-imgproc2.4v5:amd64 2.4.9.1+dfsg-1.5ubuntu1 2.4.9.1+dfsg-1.5ubuntu1.1
2019-02-27 11:55:08 upgrade libopencv-core2.4v5:amd64 2.4.9.1+dfsg-1.5ubuntu1 2.4.9.1+dfsg-1.5ubuntu1.1
2019-02-27 11:55:08 upgrade libavfilter-ffmpeg5:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:09 upgrade libcaca0:amd64 0.99.beta19-2build2~gcc5.2 0.99.beta19-2ubuntu0.16.04.1
2019-02-27 11:55:09 upgrade libavdevice-ffmpeg56:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:09 upgrade libavcodec-ffmpeg56:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:10 upgrade libavutil-ffmpeg54:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:10 upgrade libwavpack1:amd64 4.75.2-2ubuntu0.1 4.75.2-2ubuntu0.2
2019-02-27 11:55:11 upgrade ffmpeg:amd64 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:55:11 upgrade libx11-xcb-dev:amd64 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:55:11 upgrade libx11-xcb1:amd64 2:1.6.3-1ubuntu2 2:1.6.3-1ubuntu2.1
2019-02-27 11:55:12 upgrade firefox:amd64 61.0.1+build1-0ubuntu0.16.04.1 65.0.1+build2-0ubuntu0.16.04.1
2019-02-27 11:55:18 upgrade libtiff5:amd64 4.0.6-1ubuntu0.4 4.0.6-1ubuntu0.5
2019-02-27 11:55:18 upgrade libgd3:amd64 2.1.1-4ubuntu0.16.04.8 2.1.1-4ubuntu0.16.04.10
2019-02-27 11:55:19 upgrade fsl-5.0-core:amd64 5.0.9-4~nd16.04+1 5.0.9-5~nd16.04+1
2019-02-27 11:55:29 upgrade libgettextpo-dev:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:55:29 upgrade libgettextpo0:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:55:30 upgrade gettext:amd64 0.19.7-2ubuntu3 0.19.7-2ubuntu3.1
2019-02-27 11:55:32 upgrade libpackagekit-glib2-16:amd64 0.8.17-4ubuntu6~gcc5.4ubuntu1.3 0.8.17-4ubuntu6~gcc5.4ubuntu1.4
2019-02-27 11:55:32 upgrade gir1.2-packagekitglib-1.0:amd64 0.8.17-4ubuntu6~gcc5.4ubuntu1.3 0.8.17-4ubuntu6~gcc5.4ubuntu1.4
2019-02-27 11:55:33 upgrade git-man:all 1:2.7.4-0ubuntu1.4 1:2.7.4-0ubuntu1.6
2019-02-27 11:55:35 upgrade git:amd64 1:2.7.4-0ubuntu1.4 1:2.7.4-0ubuntu1.6
2019-02-27 11:55:41 upgrade gitk:all 1:2.7.4-0ubuntu1.4 1:2.7.4-0ubuntu1.6
2019-02-27 11:55:42 upgrade hwdata:all 0.267-1 0.267-1ubuntu2
2019-02-27 11:55:42 upgrade libarchive13:amd64 3.1.2-11ubuntu0.16.04.4 3.1.2-11ubuntu0.16.04.6
2019-02-27 11:55:42 upgrade libavahi-glib1:amd64 0.6.32~rc+dfsg-1ubuntu2.2 0.6.32~rc+dfsg-1ubuntu2.3
2019-02-27 11:55:43 upgrade libcurl3:amd64 7.47.0-1ubuntu2.8 7.47.0-1ubuntu2.12
2019-02-27 11:55:43 upgrade libhdf5-10:amd64 1.8.16+docs-4ubuntu1 1.8.16+docs-4ubuntu1.1
2019-02-27 11:55:43 upgrade liblcms2-2:amd64 2.6-3ubuntu2 2.6-3ubuntu2.1
2019-02-27 11:55:44 upgrade libmspack0:amd64 0.5-1ubuntu0.16.04.2 0.5-1ubuntu0.16.04.3
2019-02-27 11:55:44 upgrade mysql-common:all 5.7.23-0ubuntu0.16.04.1 5.7.25-0ubuntu0.16.04.2
2019-02-27 11:55:44 upgrade libmysqlclient20:amd64 5.7.23-0ubuntu0.16.04.1 5.7.25-0ubuntu0.16.04.2
2019-02-27 11:55:45 upgrade libnss3-nssdb:all 2:3.28.4-0ubuntu0.16.04.3 2:3.28.4-0ubuntu0.16.04.4
2019-02-27 11:55:45 upgrade libnss3:amd64 2:3.28.4-0ubuntu0.16.04.3 2:3.28.4-0ubuntu0.16.04.4
2019-02-27 11:55:45 upgrade libpolkit-agent-1-0:amd64 0.105-14.1ubuntu0.1 0.105-14.1ubuntu0.4
2019-02-27 11:55:46 upgrade libpolkit-backend-1-0:amd64 0.105-14.1ubuntu0.1 0.105-14.1ubuntu0.4
2019-02-27 11:55:46 upgrade libxkbcommon0:amd64 0.5.0-1ubuntu2 0.5.0-1ubuntu2.1
2019-02-27 11:55:46 upgrade neurodebian-archive-keyring:all 0.37.5~nd16.04+1 0.38.3~nd16.04+1
2019-02-27 11:55:47 upgrade neurodebian:all 0.37.5~nd16.04+1 0.38.3~nd16.04+1
2019-02-27 11:55:47 upgrade neurodebian-popularity-contest:all 0.37.5~nd16.04+1 0.38.3~nd16.04+1
2019-02-27 11:55:47 upgrade openjdk-8-jdk:amd64 8u181-b13-0ubuntu0.16.04.1 8u191-b12-2ubuntu0.16.04.1
2019-02-27 11:55:48 upgrade openjdk-8-jdk-headless:amd64 8u181-b13-0ubuntu0.16.04.1 8u191-b12-2ubuntu0.16.04.1
2019-02-27 11:55:50 upgrade openjdk-8-jre:amd64 8u181-b13-0ubuntu0.16.04.1 8u191-b12-2ubuntu0.16.04.1
2019-02-27 11:55:51 upgrade openjdk-8-jre-headless:amd64 8u181-b13-0ubuntu0.16.04.1 8u191-b12-2ubuntu0.16.04.1
2019-02-27 11:55:55 upgrade policykit-1:amd64 0.105-14.1ubuntu0.1 0.105-14.1ubuntu0.4
2019-02-27 11:55:56 upgrade python3-cryptography:amd64 1.2.3-1ubuntu0.1 1.2.3-1ubuntu0.2
2019-02-27 11:55:58 upgrade python3-urllib3:all 1.13.1-2ubuntu0.16.04.1 1.13.1-2ubuntu0.16.04.2
2019-02-27 11:55:58 upgrade python3-requests:all 2.9.1-3 2.9.1-3ubuntu0.1
2019-02-27 11:55:59 upgrade software-properties-common:all 0.96.20.7 0.96.20.8
2019-02-27 11:55:59 upgrade python3-software-properties:all 0.96.20.7 0.96.20.8
2019-02-27 11:56:00 upgrade sosreport:amd64 3.5-1~ubuntu16.04.3 3.6-1ubuntu0.16.04.2
2019-02-27 11:56:04 upgrade unattended-upgrades:all 0.90ubuntu0.9 0.90ubuntu0.10
2019-02-27 11:56:04 status half-configured unattended-upgrades:all 0.90ubuntu0.9
2019-02-27 11:56:04 status unpacked unattended-upgrades:all 0.90ubuntu0.9
2019-02-27 11:56:04 status half-installed unattended-upgrades:all 0.90ubuntu0.9
2019-02-27 11:56:05 status half-installed unattended-upgrades:all 0.90ubuntu0.9
2019-02-27 11:56:05 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:56:05 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:56:05 upgrade cloud-init:all 18.3-9-g2e62cb8a-0ubuntu1~16.04.2 18.4-0ubuntu1~16.04.2
2019-02-27 11:56:09 upgrade cloud-initramfs-copymods:all 0.27ubuntu1.5 0.27ubuntu1.6
2019-02-27 11:56:09 upgrade cloud-initramfs-dyn-netconf:all 0.27ubuntu1.5 0.27ubuntu1.6
2019-02-27 11:56:10 upgrade libav-tools:all 7:2.8.14-0ubuntu0.16.04.1 7:2.8.15-0ubuntu0.16.04.1
2019-02-27 11:56:10 upgrade overlayroot:all 0.27ubuntu1.5 0.27ubuntu1.6
2019-02-27 11:57:27 configure unattended-upgrades:all 0.90ubuntu0.10 <none>
2019-02-27 11:57:27 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:27 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:27 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:27 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:27 status unpacked unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:27 status half-configured unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:28 status installed unattended-upgrades:all 0.90ubuntu0.10
2019-02-27 11:57:34 configure python3-distupgrade:all 1:16.04.26 <none>
2019-02-27 11:57:34 status unpacked python3-distupgrade:all 1:16.04.26
2019-02-27 11:57:34 status half-configured python3-distupgrade:all 1:16.04.26
2019-02-27 11:57:35 status installed python3-distupgrade:all 1:16.04.26
2019-02-27 11:57:35 configure ubuntu-release-upgrader-core:all 1:16.04.26 <none>
2019-02-27 11:57:35 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:57:35 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:57:35 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:57:35 status unpacked ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:57:35 status half-configured ubuntu-release-upgrader-core:all 1:16.04.26
2019-02-27 11:57:35 status installed ubuntu-release-upgrader-core:all 1:16.04.26

User avatar
riviere
Site Admin
Posts: 1351
Joined: Tue Jan 06, 2004 12:21 pm
Location: CEA NeuroSpin, Saint Aubin, France
Contact:

Re: BrainVISA's python crashes after last Ubuntu16 upgrade

Postby riviere » Mon Mar 04, 2019 12:14 pm

Hi,
I could reproduce (more or less) the problem in a docker container (it seems a bit random, sometimes works, sometimes crashes).
I guess you are using the ubuntu 16 variant of brainvisa binary distribution (glibc-2.23), right ?
It appears that some libs got included in this package by accident that should not (some cascading dependencies got out of control...): especially libdl.so.2, the dynamic linker, which is a low-level system library, should be left to the system.
So you can remove from the brainvisa distribution, at least lib/libdl.so.2, and also probably libz.so.1.
For me it seems to fix the problem (I'm not totally sure yet because of the random behavior).
If it's not enough you can also try to move out the c++ libs: libstdc++.so* and libgcc_s.so*. They are not used by python itself (which is in C, not C++) but are used by our libs, and might also be used by other system libs (like some OpenGL/GLX implementations - we have already encountered this kind of problems).
Tell us if this works for you...
Denis

francois
Posts: 59
Joined: Tue Jul 25, 2017 9:37 am

Re: BrainVISA's python crashes after last Ubuntu16 upgrade

Postby francois » Mon Mar 04, 2019 3:39 pm

Removing all these libraries fixed python.
Thanks!

User avatar
riviere
Site Admin
Posts: 1351
Joined: Tue Jan 06, 2004 12:21 pm
Location: CEA NeuroSpin, Saint Aubin, France
Contact:

Re: BrainVISA's python crashes after last Ubuntu16 upgrade

Postby riviere » Mon Mar 04, 2019 6:15 pm

OK.
Oh there is also a libpthread.so which should be removed (we'll have to check all libs next time).
Denis


Return to “BrainVISA”

Who is online

Users browsing this forum: No registered users and 2 guests