Error at the configure step

Questions about BrainVisa usage and installation

Moderators: riviere, denghien

pron.a
Posts: 22
Joined: Mon Feb 22, 2016 10:09 am

Error at the configure step

Postby pron.a » Thu Apr 06, 2017 2:01 pm

Hello everybody,

I wanted to recompile from scratch brainvisa on a Debian Jessie machine. I followed the steps in the compilation documentation
I managed to retrieve sources of both trunk and bug_fix versions but when I launch the configure step I have error. Among all there is the error
"Policy "CMP0054" is not known to this version of CMake" . Looking into the CMakeError.log file (enclosed in this dicussion) the pthread dynamic library seems involved but I can not say much.
If you have aby ideas ^^

Have a good day

Alex
Attachments
CMakeError.log
(9.09 KiB) Downloaded 172 times

User avatar
Yann Cointepas
Posts: 316
Joined: Tue Jan 20, 2004 2:56 pm
Location: Neurospin, Saint Aubin, France
Contact:

Re: Error at the configure step

Postby Yann Cointepas » Thu Apr 06, 2017 2:15 pm

A quick look makes me believe that it is not an error in our code but in a CMake code used to assess some configuration of the system. Do you have libpthread.so installed ? On Ubuntu-16.04, it is located in /usr/lib/x86_64-linux-gnu/libpthread.so and installed by package libc6-dev.

pron.a
Posts: 22
Joined: Mon Feb 22, 2016 10:09 am

Re: Error at the configure step

Postby pron.a » Fri Apr 07, 2017 1:31 pm

Hello Yann,

Thank you for your quick answer ^^. I just checked an I have the libc6-dev package installed under Debian. It used to compile but it no longer does.

Have a good day :D
Alex


Return to “BrainVISA”

Who is online

Users browsing this forum: No registered users and 2 guests