Page 1 of 1

running anatomist on ubuntu 18.04

Posted: Thu Dec 06, 2018 9:39 am
by lmarrakchi
Hello everybody,

I am trying to run anatomist on Ubuntu 18.04

I tried brainvisa 4.4.0 and brainvisa 4.5.0 and brainvisa 4.6.0

I get a libGL error:
libGL error: unable to load driver:
libGL error: driver pointer missing

when i tried the version brainvisa 4.6.1 i got the error:
version `ZLIB_1.2.9' not found (required by /usr/lib/x86_64-linux-gnu/

Did anybody manage to run anatomist on ubuntu 18.04 and if yes is there something that I missed to do?

Thank you very much in advance,

Re: running anatomist on ubuntu 18.04

Posted: Sun Dec 16, 2018 9:05 pm
by riviere
Hi Linda,
I haven't heard of you for years, how are you ?
Well, I think this could be related to some 3D drivers using either a more recent libz than the one shipped with brainvisa, or a more recent libstdc++ (or both).
You can try moving them away from the brainvisa distribution (in the lib/ directory), this have worked for some users.

Re: running anatomist on ubuntu 18.04

Posted: Tue Feb 05, 2019 10:44 am
by lmarrakchi
Thanks for your answer Denis.
I removed libstdc++ from the brainvisa distribution and it worked perfectly.

Thank you soooo much for your help!!!!

Re: running anatomist on ubuntu 18.04

Posted: Tue Mar 02, 2021 1:25 pm
by rvboutin
For info, this was happening also with Brainvisa 4.6.1 on Ubuntu 20.04LTS, deleting the libstdc++ files also solved the issue in that configuration.