Display problems on Windows with Anatomist 4.1.0

Questions about Anatomist manipulation

Moderators: denghien, riviere

Post Reply
User avatar
Site Admin
Posts: 1361
Joined: Tue Jan 06, 2004 12:21 pm
Location: CEA NeuroSpin, Saint Aubin, France

Display problems on Windows with Anatomist 4.1.0

Post by riviere »

As some of you (and of us) have noticed (in this message for instance), the new 4.1.0 version of Anatomist encounters display problems on Windows. We have not found the cause of the problem, and have setup a workaround (but not a real fix), but this workaround proves not to work on every machine.

The problems:
1. Anatomist does not display anything, windows keep all white whatever the objects in them
2. Or Anatomist crashes when starting to display any object
3. Or Anatomist crashes after a little while after an object has been dropped in a window, especially after rotating the view

Problems 1 and 2 seem to be linked to the number of texture units used (and even just enabled). We noticed that limiting the number of texture units to 3 solved the problem on our test machines (with different 3D hardware and drivers), hence the new option "limit the number of textures", which defaults to 3 on Windows (and to "Unlimited" on other systems where the problem seems not to appear). Now it seems that some machines need to limit to fewer than 3 to work correctly. If you encounter such a problem, please try lowering to 2 or 1 texture. Don't forget to save the preferences.

If the problem still exists, you can also try to lower the level of 3D hardware acceleration in Windows display properties settings.

As the problem apprears with various hardware, it is probably a bug in Anatomist, but it seems to be tricky (it shows up only on Windows, with hardware acceleration on, and did not show up in previous versions althrough nothing has changed in the display engine code of Anatomist for a long time...) - we will investigate...

Problem 3 has been seen on one machine, and is linked to the OpenGL-based objects selection system. There is also a new option in the preferences that can be unchecked to disable this feature: "Use OpenGL selection".

Post Reply