libraries not loading - ubuntu 16.04

Questions about BrainVisa usage and installation

Moderators: riviere, denghien

csaiote
Posts: 4
Joined: Tue Dec 12, 2017 11:24 pm

libraries not loading - ubuntu 16.04

Postby csaiote » Thu Jan 11, 2018 12:22 am

Hi,

I am trying to run the morphologist pipeline but it crashes on several steps.
I successfully imported the T1 image from a .nii file and did AC/PC alignment.
After that, both FSL normalization and Bias correction failed to run and display a Signal Exception error.

I tried running the specific commands in the command line and in both cases it seems to fail to load specific libraries:
./VipT1BiasCorrection: error while loading shared libraries: libvip.so.4.5.0: cannot open shared object file: No such file or directory
./AimsFileConvert: error while loading shared libraries: libaimsdata.so.4.5.0: cannot open shared object file: No such file or directory

However, both files actually exist in the lib folder. And all users have read access to the library files.

I also ran python bv_env.py in the command line and LD_LIBRARY_PATH seems to be set correctly.

Should I set the paths in any other file?

Some more info: I am running brainvisa 4.5.0 for Linux 64 bits (glibc 2.15) (built on Ubuntu 12.04) on a Ubuntu 16.04 machine.

Help would be greatly appreciated.

Thanks,
Catarina

--
Catarina Saiote, PhD
Postdoctoral Associate
Department of Neurosurgery
University of Minnesota

User avatar
riviere
Site Admin
Posts: 1358
Joined: Tue Jan 06, 2004 12:21 pm
Location: CEA NeuroSpin, Saint Aubin, France
Contact:

Re: libraries not loading - ubuntu 16.04

Postby riviere » Mon Jan 15, 2018 12:37 pm

Hi,
Which variant of Brainvisa binary distribution are you running ? The Ubuntu 12.04 variant, or the Mandriva 2008 variant ? We have found out that both have some missing thirdparty libraries which can in some cases explain several problems (libraries not loading, or conflicts). The Mandriva version seems to have fewer problems actually. We are currently working on the next release which should not have these problems, but we're somewhat struggling to finish it with limited people and time...
Now I'm still not sure of what happens in your case.
When you are running commands from the commandline, in for instance "./AimsFileConvert", where is "." ? Are you running from the bin/ directory of the brainvisa distribution ? The commands here are actually shell scripts which should load the correct environment variables, then run the actual commands (which are in bin/real-bin).
To check you could print the libraries used (or looked for) by the commands. If you are actually in the bin directory, you could try for instance:
./bv_env ldd ./real-bin/AimsFileConvert
It should print the libs needed by the AimsFileConvert in brainvisa runtime environment (set via the bv_env program). If you see some lines containing "not found", then there is a problem there.
Denis


Return to “BrainVISA”

Who is online

Users browsing this forum: No registered users and 2 guests